Development Studio 5 (DS-5)

Development Tools for ARM Systems

ARM

Quick Start Guide

The ARM® Development Studio 5 (DS-5™)
toolchain is a complete suite of software development
tools for ARM processor-based systems.

DS-5 accelerates software development by providing an
easy to use, robust, well integrated, and professionally
maintained toolchain.

DS-5 covers all the development stages of ARM
processor-based products, from platform bring-up to
application profiling, while including a number of ARM
Linux and Android™ specific features.

This Quick Start Guide is intended to help you through
your first steps with DS-5, from installation to
launching and using each of its component.

What’s New!
Extended Target Connection

DS-5 Debugger supports the connection to a variety of
target types, from programmer’s view models and RTL
running in EDA environments, to physical implementations
on FPGAs and ASICs.

For development of Linux and Android native applications
and libraries, DS-5 also supports the connection to the
gdbserver debug agent over a low-cost Ethernet or USB
interface.

Target Connection

ARM Fast Models

CADI Virtual
RTL Simulators VSTREAM Virtual
Hardware Emulators VSTREAM Virtual

FPGAs and ASICs DSTREAM JTAG or Serial-Wire Debug
Linux applications TCP/IP Ethernet or Serial
Android applications ADB uUSB

DS-5 includes target configuration utilities to facilitate the
bring-up of new SoCs and boards, and to configure the
CoreSigh'cTM debug and trace fabric of the target.
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GPU Profiling and Energy Analysis

The ARM Energy Probe adds energy analysis capability
to the ARM Streamline™" performance analyzer, which
enables developers to correlate the target’s power
consumption with software activity and events.

Streamline also supports complete system-level profiling,
by merging information from the CPU, graphics processor,
system caches and Fabric IP into one single report.This
report visualizes the interactions between the different IP
blocks.
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Getting Started with DS-5

Downloading DS-5

Download DS-5 and a 30-day free, fully featured, evaluation
license from www.arm.com/ds5. Alternatively, request a
DVD from your local ARM office or tools distributor.

DS-5 is regularly updated with new functionality. In order to
use its latest features, just install the latest version available.

When you purchase DS-5 you are entitled to technical
support and access to free updates for one year.

Running DS-5

Most of the functionality in DS-5 can be accessed from its
Eclipse-based graphical environment.

On Windows hosts, launch Eclipse for DS-5 from the
Start Menu » Programs » ARM DS-5.

Installations on Linux hosts include a script to install and
uninstall application menus. Alternatively, execute eclipse
from <install_directory>\bin.

When launched, Eclipse prompts you to specify the location
of a Workspace, where your Eclipse settings and projects
will be stored.We recommend that you create one or more
new directories to be used as DS-5 workspaces.

Welcome Screen and Licensing

At any time you can open the DS-5 welcome screen by
selecting Help > Welcome.This screen provides links to
examples, docs, hints and tips, and support resources.

In order to license DS-5 follow the instructions on Help

» ARM License Manager... The license manager provides
assistance to obtain and install a DS-5 license key associated
with your host machine. Both node-locked and floating
licenses are available.

Click on the Go to the Workbench link to close the
welcome screen and start using DS-5.

Environment Variables

The DS-5 installer does not modify any environment
variables in your system.

DS-5 only requires that the path environment variable
points to the <install_directory>\bin directory.This is
done automatically if you launch the tools from the Eclipse
for DS-5 or the DS-5 Command Prompt items in the
Windows Start Menu.

Running the tools from a Linux console requires that you
manually set the path environment variable.

System Requirements

The minimum computer specification to run DS-5 is:
m 2 GHz dual-core host processor

m 2 GB of RAM (4 GB recommended)

m 2 GB of hard disk space.

DS-5 supports the following x86 host platforms:
m Windows XP Professional service pack 3 (32-bit)
m Windows 7 Professional and Enterprise (32/64-bit)

m Red Hat Enterprise Linux 5 Desktop and
Workstation (32/64-bit)

= Ubuntu Desktop Edition 10.04 LTS (32-bit).
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The DS-5 welcome screen links to useful information such as
video tutorials, step-by-step guides, examples, and documentation.
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DS-5 includes support for Japanese localisation, both in its
graphical user interface and command line.

2 DS-5 Quick Start Guide



Eclipse IDE and Project Manager

Eclipse Perspectives and Views

A typical Eclipse workbench window contains one or more
perspectives, each of them including a set of related views,
editors, menus, and toolbars. L]

DS-5 Example Projects
DS-5 includes a range of examples to get you started:

Startup examples include reset, MMU and cache
initialization code for ARM and ARM Cortex""
processors.

The main Eclipse perspectives in DS-5 are:

m C/C++:used to import and manage software projects,
and to edit source files

m DS-5 Debug: graphical interface for the DS-5 Debugger.

m Fireworks is an example bare-metal application
ported to the RTSMs, Beagle and Panda boards.

m Hello World bare-metal examples are ported to

DS-5 also includes other perspectives, such as PyDev for . X ’
many of the boards in the configuration database.

coding debugger Jython scripts.

m Distribution is a complete Linux distribution for the
Beagle board and the Cortex-A8 Real-Time System
Model, to enable driver and application development.

To open an Eclipse view, go to Window » Show View.
Change the position of any view by left-clicking on its tab
and dragging it. The new location can be adjacent to existing
views or in a tabbed group. m Gnometris is an open source Linux application

Detach (undock) the view to drag it to a second monitor, similar to the game Tetris.

or right-click on its name to add it to the FastView bar. m Example_library demonstrates how to create a
simple shared library in C for ARM Linux.
Import Exa’mple Pro;ects m Threads is a simple multi-threaded Linux application
From the C/C++ perspective, select File » Import... that illustrates how the tools handle multiple threads.
General > Existing Projects into Workspace. = Xaos is an example fractal application, which comes

Activate Select archive file and choose an example zipfile with a pre-generated Streamline report.

from <install_directory>\examples\example.zip. = Kernel_module illustrates the kernel awareness

features in DS-5 Debugger. Note that it needs to be

The examples are decompressed into your workbench
built on a Linux host against your Linux kernel.

directory and appear in the Project Explorer view.

Create and Build Projects

Right-click on the Project Explorer and select New » C or
C++ Project.

Select one of the six project templates in the DS-5 project
wizard: bare-metal executable or library, Linux executable,
shared library or static library, and makefile project. This
creates a new project with working pre-defined compiler
settings.

Template-based source and header files can easily be added

to a project. Right click on the project in the Project
Explorer view and select New P Source File.

The DS-5 IDE includes powerful features to assist coding of
C/C++ and assembler files. These include syntax highlighting,
code auto-completion, and quick-jump to declaration of
variables and functions (F3 short-cut) .

Find-in-files tools are grouped under the Search menu.

To make or build a project, select Project » Build.

C/C++/asm Code Function, class and
syntax coloring auto-completion variable definition
Z0Swoid
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Source code editing features in the DS-5 Eclipse IDE
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Target Connection: Bare-Metal and Driver Debug

DSTREAM

The ARM DSTREAM™ Debug and Trace Unit provides
DS-5 Debugger with high-performance low-level debug and
trace connection to hardware targets.

DSTREAM enables DS-5 Debugger to bring up a platform
and debug bare metal software in stop-mode, with full
access to the processor and system resources.

Thanks to its large buffer DSTREAM supports long-term
off-chip trace.This enables the debug of complex, time-
related software bugs, and performance optimization of
critical code.

DS-5 Configuration Database

DS-5 provides pre-configured JTAG and trace for
catalogue devices. Just choose a device on the Debug
Configurations dialog to connect the debugger to one of
these targets.
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The default DS-5 configuration database is stored on
<install_directory>\sw\debugger\configdb. However,
you can add custom configuration databases by selecting
Window » Preferences > DS-5 P Target Database.
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Debugging Custom Devices

The tools required to bring-up new SoCs and boards, and
add them to the configuration database are provided in the
DS-5 installation:

m CSAT:This command line-based tool enables manual
control of the registers of a CoreSight Debug Access
Port and script access to the IP blocks connected to it.

m Debug Hardware Configuration: This graphical
utility reads the contents of a CoreSight ROM Table to
auto-configure the target connection. It also enables
manual configuration if the table is incorrectly set up.

m ConfigDB Import: Use it to import the new debug
hardware configuration into a configuration database.
This utility outputs DTSL Python scripts (.py), which
can be used to manually modify the configuration of each
IP block with a simple scripting language.

-

JTAG and Serial-Wire Debug
2.5 MB/s

600 Mbps/pin (16-bit)
300 MHz DDR

Trace Speed
Trace Frequency

DSTREAM features.

1V to 5V target interface,
configurable by target

Clear visual indicators for
target status

to Mistral EVM

DSTREAM connection . f

USB 2.0 or Ethernet
connection to host

Direct target connection
for optimal signal integrity

Low-Level Debug Features

DS-5 Debugger implements support for the latest ARM
processors and technology:

m Multi-core debug: DS-5 supports AMP and SMP
configurations, as well as big.LITTLE systems

m Linux kernel awareness: visualize and access kernel
threads and modules on single and multi-core targets

m Hypervisor debug: access memory in hypervisor
mode and set virtual machine-dependent breakpoints

m Direct memory access: using the AHB-AP port of

the CoreSight DAP for fast memory download and
debug of running systems.
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Target Connection: Linux and Android Application Debug

Connecting to the Target

All you need to debug and analyze Linux applications on an
ARM processor-based target is a TCP/IP connection
between the target and the host computer.

Android middleware and native application development
normally uses an Android"" Debug Bridge (ADB)
connection over USB.

DS-5 Debugger supports both connection types, and can use
them to automatically download applications into the target
file system, launch the gdbserver debug agent on the target
and connect to it.

DS-5 requires gdbserver v6.8 or later. The installation
includes gdbserver v7.0, which enables debugging NEON™
code and multi-threaded Android libraries.

Linux Target File System

DS-5 integrates a Remote System Explorer (RSE) to
access the Linux file system on hardware targets that
support the Secure Shell (SSH).The target must include a
secure shell daemon (sshd) and sftp-server.

RSE enables the following functionality:

m SFTP FilesView: Access the target’s Linux file system
using an FTP connection. Navigate, copy, paste, drag and
drop, and edit files on the target

m Shell Processes View: Displays a list of current
processes running on the target

m SSH Shell/Terminal View: Opens a shell or a terminal
window connected to the target in order to execute
Linux commands - for example to run an application

m Automated software download: DS-5 Debugger uses

RSE connections to automate the download of images to
the target, executing gdbserver, and connect to it.

Configure Remote System Explorer
Open RSE by selecting Window » Show View »
Other... » Remote Systems P Remote Systems.

Click on the New Connection button . Select Linux
and click Next.

Fill the Host name box with the IP address of the target
system, or its network name if it is registered on a DNS
server. Define a name for the connection and click Next.

In the next configuration steps choose the Secure Shell (ssh)
option, then click Finish.

Real-Time System Models

DS-5 includes Real-Time System Models (RTSMs) of
Cortex-A8 and Cortex-A9 processor-based SoCs.

An RTSM is a fast simulation model of a complete SoC
with a processor, system memory, and peripherals such
as keyboard, mouse, UARTs, Ethernet, and LCD.

RTSMs enable ARM bare metal and Linux software
development without any hardware, and deliver
simulation speeds of over 250MHz on a typical desktop.

DS-5 includes an example ARM Linux distribution
ported to the Cortex-A8 RTSM. When launched, the
model automatically boots Linux and enters a state in
which you can load and debug your applications.

RTSMs are configured to mount a Virtual File System
(VFS).The processor running in simulation can access
files in the host computer’s file system as if they were
part of its ARM Linux file system.
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Starting a Debug Session

Launching DS-5 Debugger

Click on the down arrow of the Debug button % = on the
menu bar, or right-click on the Debug Control View to open
the Debug Configurations dialog.

Right-click on DS-5 Debugger and select New, or browse
existing debug configurations. If you have imported the DS-5
examples into the Workbench, the Debug Configurations

Dialog is populated with pre-configured target connections.

Existing debug configurations can be launched by double
clicking on the Debug Control View.

Use the Debug Control
View to manage your
debug configurations

Open the debugger
launcher to configure the
connection’s properties

Adding Custom Plug-ins

Eclipse plug-ins can connect to the DS-5 Debugger using
a Java-level API. Its target application is RTOS awareness
plug-ins, but could be used to visualize graphically any
target data structures.The API enables:

m Read memory from the target

m Decode the address of symbols (e.g. variables)

Add custom tabs to the Debug Launch dialog

Get notification of the target’s status (e.g. stopped).

Select a target from the
configuration database or
a gdbserver connection

The project types
available depend on the
type of target selected
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Use the other tabs in
the dialog to configure
connection options

Load an application’s
symbols to enable
source-level debug

Use this option to attach
the debugger without
stopping the target

Use debugger scripts to
initialize the target and
the debug session
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DS-5 Debug Perspective

DS-5 includes a fully featured graphical C/C++ debugger.
Open it by launching the debugger from the Debug
Configurations dialog, or by clicking Window » Open
Perspective » Other... » DS-5 Debug.

Alternatively, the debugger can be used from the host’s
command line interface, or from a Jython script.

Each debug view is self-contained, so there is no need to
configure any options using the Eclipse main menu. Note
that some of the debugger views, for example the Trace view,
are only enabled for JTAG target connections.

Take time to explore the toolbars of each of the views. Press
the down arrows * to see more buttons and options.

Click to focus the system
views on a connection,
core, thread or stack frame

Control target execution
with source and assembly
level stepping

Type GDB-style commands
with auto-completion

Switch between the
C/C++ and DS-5
Debug perspectives

Drag & drop lines from
history view to scripts

and on-line help view to create a script
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Source and assembly
code views synchronized
with color coding

FastView bar for
minimizing often-used
debug views

Click the down arrow to
access the sub-menu, and to
freeze and replicate views

Link the view to the active
connection, or to a fixed
connection or processor

Screen buffer and system
views have multiple
formatting options
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Instruction and System Trace

InStru ction Trace The code view tracks Export trace entries Zoom from | to
Instruction trace enables the non-intrusive debug of random thet:'::zazzliic:vd in t°:::;1€|5:i‘:r '0'000;’:5:'21“'“5
time-related issues, which are difficult to replicate by P 4 P

stepping through the code, and the performance analysis of
critical areas of software.
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When trace is enabled, the debugger records the last
instructions executed by the target. When the execution
stops, the trace view is filled with a history of instructions

around a trigger point, synchronized with the code view. & \ ¥ >
Instruction trace requires a JTAG connection to devices 4t Trace i e € o3 HOTE 1 01 O - B~ ¥
featuring an Embedded Trace Macrocell (ETM) or I i corks-pande-ecampleiCortex-AS 0 -
Program Trace Macrocell (PTM). | Trace | Properties | Rangss|
The number of instructions recorded is limited by the size of :r:j\:rjeSnark-____ =
the on-chip Embedded Trace Buffer (ETB). If you need a randorm 0,42%
larger buffer, trace off-chip to the 4GB buffer on DSTREAM. . | ®
. . . — Index fddress I Dp ads | T

Using Tracepoints and Filters L e ~7T

(-5, 644/ oxanoonsiz|7azn | |STRB =), (=440
By default, DS-5 traces all the instructions executed by the - /M(EDDDDEED e =h, 80
processor into a circular buffer. The contents of the trace Ox20000522 @ BEHQ T pab+0nis
buffer are collected, decompressed and displayed when the it Lom £, [£d, #0]
target stops - for example, when hitting a breakpoint.

. . View tracepoints and Use the Properties H £ activi
Trace start and trace stop points enable you to restrict triggers embedded in and Ranges tabs to eat::afl: :c t;cl:;w't)’
trace to certain areas of the code.This is useful to optimize the trace list configure trace P
the analysis of certain functions when tracing to an ETB, or ]
Trace View.

to prevent ETM FIFO overflows when the trace port is slow.

Ranges (also called filters) can be used in conjunction with — — —
trace start and trace stop points. They enable you to select D Nipfisgethiogram.c |

: : . . “9:55.348 ‘Hello world 595848
an address range outside of which trace is always disabled. 955810 Heltaworld 535349
10:08.930 Helip world G@8E36

Triggers are highlighted on the trace view, and can be used i gk ippusin fepinit
to identify and search interesting areas in the code. In 1.2 Evert Yigwer 10166.041 tello world egER4l

addition, triggers enable you to configure the tools to collect 1@;68.842 :E‘ﬂ'—’ *'-'0":1[: :33942
> . 16:22.138 22138
trace around, before, or after a certain instruction. Just check G Ta it Grares
. . " . [¥]Enable ITM capturs e 7
the Stop on Trigger box in the trace view’s Properties tab 3 st 18:22.141 Hello world 622141
to trace around a trigger point. e analsis frace depth | 1ME: |
System Trace

[T Charmel Configuration
The Instrumentation Trace Macrocell (ITM) and
System Trace Macrocell (STM) provide high-bandwidth,
low latency “printf-style” instrumentation links.

E] M Chamnel | 1 = | Encodig |ENCODED. % | Fils Gutput

The output of ITM and STM is routed to the on-chip trace _
bus, and can be collected by the debugger and displayed on [—] I Channel | 18 2 | Encoding | RAW TERT % | Flls Sukplt

its Event Viewer or exported to a text file. } -
ciukput File: | Ciwarkiu.log

The EventViewer can be configured from the EventViewer
tab of the Debug Configurations dialog. Event Viewer configuration and output.
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Debugger System Views and Target Control

System Views

The variables view shows the value of all the application’s
variables under three groups: locals, file statics, and globals. It
also displays each variable’s type, size, value, and location
(either register or memory).

If you are interested in a defined set of variables or registers,
just type them or drag them to an expressions view.This

view also offers the flexibility to watch any C-like expression.

For bare metal development, use the register view to view
the processor, co-processor, NEON and peripheral registers
with the same format as in the target’s documentation.

The functions view lists all the functions in the target’s
application, and can be used to set breakpoints and trace
points, or navigate to the source code of a function.

Using the System Views

All the system views use color-coding to highlight content
that has recently changed, and most support drag & drop.
The code view shows variable values by hovering over them.

System views can be frozen or replicated for comparing
data between two points in time. Most views also accept C-
like expressions. For example, you can set the value of a
register with an expression such as (*my_ptr) & Oxffffff.

The way the debugger accesses the memory system (e.g. as
bytes, words, or multiple words) is configured via the
memory map.View the memory map with the info mem
command, and configure it with the mem command.

Breakpoints and Watchpoints
Set new breakpoints or tracepoints by double clicking
on the left column of the source code or disassembly views.

Set new watchpoints (data breakpoints) by right-clicking
on a cell of the memory view or a global variable in the
variable or expression view.

Edit the properties of breakpoints to assign:

m Condition: the breakpoint only stops the execution if
the condition (a C-like expression) is evaluated true

m Ignore count: number of times the breakpoint is hit until
the application stops

m Run script: the debugger performs an action (e.g log a
message) automatically when the breakpoint is hit

m Thread and virtual machine-specific breakpoints
stop the processor only when hit from a certain thread.

Address Modifiers

You can use address modifiers to select a certain type of
memory or target access. For instance, if you type S:0x0,
the debugger reads the content of memory at address
0x0 in TrustZone secure mode.

This is a list of the available address modifiers:
m P: Physical memory (MMU disabled)

m S:TrustZone secure mode

m N: TrustZone non-secure mode

m H: Hypervisor mode

m DAP: Direct memory access via the AHB-AP port of
a CoreSight DAP. This port enables debugger access
to physical memory with a running target.
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Starting a Performance Analysis Session

ARM Streamline Performance Analyzer is a system-level
performance analysis tool for Linux and Android systems. It
uses sample-based profiling, Linux kernel trace and software
annotation techniques.

Streaming data over TCP/IP
enables long-term data capture

Type the name to be used for
capture and report files

Iarme

Setting up your system

To get the most out of Streamline you need:

Connection

fddress: | 169.254.0. 100

"

SampleRate! |Mormal % Buffer Modsr Streaming % | Durakiord

[¥] zall Stack Unwinding
{91 Process Debug Information

[ THigh Ressluticn Timelins

Caphure

m TCP/IP connection to the target, using an Ethernet link
(Linux targets) or ADB over USB (Android targets)

m Build the gator module with the target’s Linux kernel
and copy the gator demon to the same directory. Gator is
licensed under GPL, and works on Linux 2.6.32 or later

Cutpul Path: | ${streamline_resuftsH@F @ [Wl:'l'rli.f-_parj... l 1FI|E Syieber, ., |

m Enable frame pointers when you build your application Ci\Templinstallations|Energy_Meter | | Warkspacd:.. | [File System. .. |

and libraries for Streamline to generate call-path reports

Ereray Tool Path;

Program Images

] [5) =

@ik ${WD‘P%_IUC:x:ans}'l,:scans-B.S'l,hanans

= Annotate your code with a printf-style interface to the
gator driver, to highlight important software events

m Add custom counters to Streamline by pointing to
their address in the memory map in the gator driver.

@ o) ] (o ) L e

Launching Streamline

In Eclipse, open the ARM Streamline Data view in the
Streamline perspective.Alternatively, start a capture and
generate reports from the host’s command line with the
streamline command.

Streamline generates code-level
reports for selected images

Check this box to generate call
path and stack reports

Streamline Capture Options Dialog.

Type the target’s TCP/IP
address and click “play”

Open capture and counter
configuration dialogs

List of available processor
and system counters

List of counters to collect
and to sample with

Click here to enable
event-based sampling
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Double-click on a capture
file to generate a report

Double-click on a report

file to open it

Integrated counter
documentation

Number of events that
trigger an event sample

Import and export counter
configuration settings
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Streamline Profiling Reports

Na‘VIga‘tlng a Streamllne r'epo"'t Call tree shows processor time All table-based reports can be
A Streamline report provides a great depth of spent on each individual call path exported to text files
performance-related information on seven panes: Timeline, !

. . Timeline | o Cal|l Paths | Furctions | itk Code | =< Call Graph | | Skack: 4 Log | 1
Call Paths, Functions, Code, Call Graph, Stack Analysis and L @ = )I e

Logs. O A =

Start with the Timeline and Functions for an overview of

Self | Pmcess‘"'fntal . Stack | Process|Thread/Function Mame

the execution. Use the other panes to focus your analysis. 0.00%  100,00% 63,70%. 0. [ide]
. CiO0%  100.0%  1043% 0+ [kermel]
Use the tabs on the top to navigate between the panes. 0.00% 100,00% 8,10% 0 = [cori s mall sk sndroidndk,bitorisleobe #7468]
Alternatively, right-click on a function name to highlight the 2.:00% al 7. UL St [Thizad-16 412058
fi . h 0:00% 2823% 2.29%. g2 = Java_com_arm_mall_sdb_andraidndk_tuterish
unction on another pane. B oo 220% 125 | | | renderFrameting
17.02% 1.28% B | | _nedz

Sampling on events 196%, 087% U | | | fleatsid

11.11% 080% i |- _aeahi_dadd

&

By default, the Streamline profiling reports are generated by — , E
. Sarnples w  Instances - Licaticr
sampling the program counter every 1ms or 10ms. i = : S
% L A b {0 e e
When you enable event-based sampling, Streamline takes : :'—;Eft;df :::‘-”
LIy [x} S0
samples when an event counter reaches the Threshold value . 0 G e lbesa
selected. These samples fall on the instruction that caused - 1 ple [IbTutarialCube.sa] IbTutrialCube so
the last event, and are used to fill the profiling reports with ! i'—ﬁ:—;ﬂﬁ'a ey
event-based data instead of time-based data. |
For example, event-based sampling can be used to explore Color-coding assists with the Profiling report for the selected
which parts of the code are causing cache misses or branch identification of hot spots process, thread or call path
mispredictions. This feature requires PMU sampling support
on the target and its Linux distribution.
Color coding makes it easy to identify hot spots Function usage highlighted with color coding
Bl mimefine: | zall Pathe | @) Functions |5} Code| =< call Graph | B Statk @ Log | > HT'rrnahna o zall Paths | Gy Functions | (i) Cods =< Call Graph | 5 Stack & Lo_g-”.l
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Profiling data is reported down to Select a line of code to see its The mini-map shows all the Click on a function to highlight
source code or assembler level matching assembler code functions in the code callers and callees
Open a source file in the code view to deepen the analysis The call graph displays the relationships between functions
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Streamline Timeline View

Charts show Linux
events, processor and
system counters

Activate the X-Ray
mode to show core to 100us or less
to thread affinity per slot

/ [

Timeline - Calllaths | @ Funchéns | jiip Cods =40 Call Graph = Brack: 4 Log iWamngs \

@ NEER w6 2

Zoom from |s Navigate the view
easily using the

timeline overview

Use the calipers to
filter the captured
data on time

Highlight points of
interest with time
bookmarks

N
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Expand charts per
core and threads
per process

The process pane
shows thread and
process activity

Visualize thread heat
map or core to thread
affinity (X-Ray mode)

Mark software events
with text and visual
annotations

Aggregate for a period
of time counter and
sample information

Correlate aggregated
counters with a
function-level report

Find out more about DS-5

Web resources include product download, information and documentation, knowledge articles, support forums and sales

contacts. For more information see www.arm.com/ds5 and www.arm.com/dstream. B RM
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